Comments 29

  1. Pingback: Das C64 Textadventure ‘Das Geheimnis des Schloss Arendarvon’ | Freelancer Martin Zeller

  2. Do you have larger versions of the maps? I’m trying to translate them into English and I can’t see the actual letters of your (Dutch?) words so I can computer translate them (my Dutch knowledge is near zero).

    Thanks for thinking of a near forgotten adventure.

  3. Post

    Hi Martin,

    I created these maps many years ago, and lost the bigger versions. Maybe it’s time now to draw new ones 🙂 The texts are in German. Do you need them for playing or for your own web site?
    My site is available in Dutch and in German – and I’d like to create an English version too… because I own the English version of the book… maybe we can help each other!


  4. Hi! I am playing Arendarvon Castle, and have managed to update and complete your maps. Are you interested in a (dutch) copy with notes of object I found where?

    I have not been able to complete the game yet, as I have no book and have not been able to find it anywhere, so I do not know what the purpose of the game is. Do you know if anybody has a scan available of the book in dutch, english or german?

    Sincerely yours, Karen

  5. Post

    Dear Karen!

    I am very interested! It would be nice if we could share your copy with the community 🙂

    Since monthes I’ve been thinking about scanning my english and german version of the book, but it would be a lot of work! Still I am waiting for the progress of technology in this point (e.g. )

    Please send me your copy – and I will see how much you have discovered so far and I will scan some important pages for you!

    Kind regards

  6. Hi Martin,

    Did you recieve the maps and notes (doc file) in good order? My dad helped me by using a hex-editor programm to figure out what words are needed in the game. I have come to the conclusion that I miss some kind of glowing-spell (we have found 7 other spells). Perhaps you could email me a hint on where to look for it… I’ll then try to put it in the encyclopedia (as that is the object closest to a “magic cube” that I can find in the Dutch game…). Thanks! Karen

  7. Hi Martin and Karin,

    I did visit this site a while ago. I was writing something on another website today about this game ( and stumbled on this site again searching some info about the german version of the game. Nice to know I’m not the only one trying to solve the game. I do own the english and dutch version of the book. I did play this a year ago and as I remember the purpose is to retreive all te spells from the game and leave the castle with them without using the spells to obtain a maximum score. I did find all the spells but couldn’t manage to complete the game without using some of the spells. I started to play again last week because I cracked the game to visit each location hoping to find something I missed the first time. Would be nice to finally solve this game. Have to find my old notes though which won’t be easy because they are somewhere between all my other papers about games:).

    I play the dutch version of the game. I never found the english version on the internet and although I did have plans to enter the english version from the book I never did it untill now.

    I did finish the other book from Hal Renko The antagonists. I published the solution on the above mentioned website. There should be a third game called the Seventh generation but alas I did never find a copy.

    Kind regards,


  8. Hi Alex,

    From the author of the game I have obtained a scan of the English book. I play the Dutch and the German version of the game, but am still unable to find the “Magic Cube” (or is it the “magische eenheid” in the dutch game?) and if I need to put something in it.

    Nor can I find the 8th spell (glowing spell). In the book at first it is written there are 7 spells to be found, at the end of the book there is word of 8 spells (and indeed a glowingspell is in the list of words readible in a hex-editor).

    I have looked at the items and noticed I get 1 point for each room/section I enter. Each spell gives me 20 points (used 15) and the “magische eenheid” is also 20 points (perhaps that is therefore this magic cube to be found?). I still have no clue what to do with the items found. (By the way: if you like a copy of the map I drew, too, just let me know, you can find me through the arendarvon forum on facebook).

    On your suggestion I just walk out, finding myself to have scored 191 points… What was your score? And do you know if the game at some point tell you it is finished? I mean, I can also leave the game right after entering, scoring just 1… but the message it gives is the same…

    As for the Antagonists: we have finished playing the antagonists and left this earth by roaring rocket (and while checking your walkthrough came to the conclusion we did the exact same thing, just needed more trials-and-errors and running-arounds in the dark maze). 🙂

    Kind regards,

  9. Hi Karen,

    Just a fast response because I almost have to leave now. I also made a map, but it would be nice to compare it with yours. The game has 117 different locations. The German version has 86 commands (verbs and nouns together). The dutch and the English version know 91 different commands because they also have some alternative commands like for instance KLIM and BEKLIM in dutch. The game has 50 different objects and including you has 9 different characters. I’ve some lists of all of these in excel in German, Dutch and English if you are interested..

    Because I couldn’t find it on the internet I’m typing in the English version for the c64.

    The “magische eenheid” (Dutch) or “einheit” (German) is called reservoir in the English version. You can find it in the study, but sometimes the wizard takes it. Note that the wizard on the stairs is another wizard then the one you encounter upstairs.

    I did use some of the objects but not all. I’ll give a list of the objects I used one of these days when I’ve some more time to write. Allthough I did find all the spells it seems that I still have to solve some puzzles to end the game correctly.

    I didn’t find for instance any use for the knife, staff, armour, book of secrets, flask, blue liquid, still (kruikje/krug), telescope and reservoir. I don’t know what is the use of the priest. I did use the charm spell on the custodian to obtain his keys but I don’t know if there is some other method. I used the kill spell to kill the wizard and to be able to take the things he has but I don’t know how to do this without using the spell. When you use the charm spell on the eagle he gently takes you down but I don’t know how to do this without magic.

    To obtain the glow spell you need the help of the rat. Give him something and he will give you some objects in return. (If you don’t succeed I’ll tell you how to do it).

    The highest score I got was 200 but I used some of the spells to solve the game. I asked the author if it was possible to solve the game without using the spells in order to solve the game with the maximum score of 240 but unfortunately he didn’t answer my e-mail.

    Kind regards,


  10. Hi Alex,

    Thank you so much for the glow-spell tip! I have been given a lot of presents by the rat, but not the glow-spell yet (mostly dollarbills with which I could then bribe the gatekeeper). I had figured out there were an alchemist and a wizzard in the game, but as far as I know the alchemist doesn’t do anything.

    In my game the eagle also drops you without using the charmspell if you tease him enough (true, a bit less gently, so you do lose some strength probably). The priest is your key to the rope in the chapel and the book of secrets that enables you to open the secret door in the gallery. Also, giving him objects and waiting one round makes him bless you (= your powers increase) – make sure you leave straight after, the second time you encounter him, he will be cranky again, having you lose powers… I am still trying to figure out a way to kill the gardian to obtain his keys without having to use the charm or kill spells on him. Just taking the keys thusfar has been unsuccesfull (from the girl I could just take the money after a few tries)…

    Could you please try to contact me through Facebook (arendarvon forum)? So we can exchange email addresses over the internet, without putting them up for everybody to see 🙂 I can then send you the maps I’ve made and the wordlists / found objects.

    And I am sure, Martin -owner of this forum- would be very interested in your findings too!

    Thanks again for the suggestions! Good luck with programming the c64 version. (By the way, have you ever thought of writing to one of the authors? They have the programms typed in, for sure!)

    Regards from a very wet North of the Netherlands

  11. Hi Alex and Martin,

    I figured out that if you take the book of secrets from the cupboard (or from the priest, but it’s a pity to use strength for that) the secret passage door to the stairs to the medieval-bedroom-with-rope opens. Also if you have it in your possession the door opens. With the book of secrets, the collection of documents and the encyclopedia of magic (containing the sesam-spell) I can go through the secret door and by turning left straight straight afterwards (not going down the stairs) another secret door opens and allows me to enter the guestroom. From there I can walk towards the stairs. When I encounter the custodian/guardian on the stairs, I can take the keys from him. But I am thrown in the cellar for that most of the time (I did manage once to get them and walk away…).

    I have been feeding the rat the food by opening the provisionroom, and it does give me a lot of things: a snippertje papier, a reepje papier and a stukje papier, all of them turn out to be dollarbills, no glowing-spell however. Giving the rat the collection of documents (Lords read it, Rats eat it, I bound it, no-one has found it) I have tried, but it does take it as food, nor when I put it down and wait, so I would appreciate a tip on how to feed the rat exactly…

    The liquid is something you can drink to obtain strenght. The kruikje exploded when I tried to do something with it. The knife can be used to attack people, but thusfar I have been wounded in trying. For the staff, harnas and telescope, I have found no use either…

    Did the magic-alphabeth-riddle in the SEtower do anything (the facing north and turning three times right to go forwards) for you? I have tried it in many rooms, but have not been able to observe any changes… Thusfar, in the game, I have not encountered the inscription, so perhaps it only exists in the book?

    The reservoir is a reservoir of Force, as it is worth 20 point (as are all the spells). I have assumed this to be the Magic Cube, am I mistaken?

    I have tried to figure out how many room-visiting-points there are in the game (40) and knowing that leaving the castle across the bridge generates another 10 points, I come to the conclusion I ought to be able to get 8×20 (spells) + 1×20 (magic reservoir) + 40 (roompoints) + 10 (bridgecrossing) = 230 points. As I do need the sesam-spell to get myself out of the cellar and probably one of the other spells, too, and I loose 5 points for each time I use a spell, I would say I miss 20 points: it would make sense if there is a true Magic Cube to obtain that is worth 20 points as are the spells each…

    If you have figured out other ways to render points, I am very curious!

    @ Martin, if you like a renewed version of the maps including the rooms that generate a point when visited-and-left, just let me know.


  12. Hi Karen,

    Just read your message. A quick response:

    If you’ve got all three pieces of paper type ONDERZOEK REEPJE (UNTERSUCHEN PAPIERSTREIFEN for the German version or EXAMINE SCRAP for the English version) or one of the other pieces of paper and they form the glow spell. It’s a very useful spell to investigate everything. It lets you see all things which are in the possession of someone or which are inside something.

    If you give the girl the ring, she lets you take the money without screaming. This way the custodian won’t be mad about you for having taken her money.

    The reservoir is the magic cube I suppose.

    You don’t need the sesam spell to get out of the dungeon. If you examine the walls you notice there is a hole in the east wall. Hit it until is becomes bigger (SLA GAT or SCHLAGEN LOCH or STRIKE HOLE depending which version you play) and you can walk through. I need the kill spell however to get rid of the wizard in the tower and to take the things he has taken. I assume there has to be some other method to achieve this. Maybe using the liquids in some form.

    I also did not find any use for the inscription.

    After drinking the red liquid (PAK DRUPPELS, NIMM TROPFEN or TAKE RED) I was able to lift the still (KRUIKJE /KRUG) but I don’t know what’s the use of it. If you break it when you’re in the same room it kills you when it explodes. Wearing the armour doesn’t protect you either. Maybe you can drop it somewhere?

    If you drink the blue liquid from the flask (PAK VLOEISTOF, NIMM FLUESSIGKEIT or TAKE BLUE) you awake inside another room.

    I finished typing the English C64 version but unfortunately the game gives an error. I already detected an error in the “Tuesday” program code but comparing it with the Dutch version was able to correct this one. I guess the error is somewhere inside the “Saturday” code.

    It’s a bit late now ? but I’ll give the game another try tomorrow to see how many points I can get.

    Kind regards,

    PS I can’t find the arendarvon forum on facebook, but I guess I found your profile because there was only one Karen who is a friend of Martin and the author of the book on facebook . I guess that’s you? If so I’ll send you my e-mail.

  13. Post

    Dear Karen, dear Alex,

    sorry for not taking part on your discussion – lack of time.
    But I can tell you that in my english version of the book there is an “erratum” with three parts of code which have to be replaced in the last part of the program listing. Maybe this is the solution?
    I will publish it tonight.

    Thank you

  14. Hi Alex,

    Yep, that would be me!

    I have had all three pieces of paper, but have not tried to examine them while in possession of all three, I suppose!

    And hitting the gap? I did try that, but nothing happened. I’ll try again!

    I suppose it is an idea to use the blue liquid to escape from the enchanted room!

    Oh, I gave the pieces of paper I obtained from the rat (even without feeding him, he gives them to you, but not as quickly) to the girl to ask her money. The money however, does not seem to be necessary as I can escape from the gatekeeper without bribing him too. Does the girl do anything for you after giving the money? She keeps asking if she can help…

    How come the custodian in my game is always cranky and puts me in the dungeon even if I did not take the money from the girl… Hmmm, it must have something to do with the sequence in which I visited the rooms. I;ll try again tonight!

    Thanks! I am sure will crack the code and leave with 240 points in the end!

    I await your FB reaction and send you my maps,

    1. Post
  15. Hi Karen and Martin,

    Maybe the turning right in the enchanted room is what is meant with the inscription of the tower. I know the exit is to the west and turning three times right facing north, points you to the west. I will try it tonight when I’m at home. As I remember I opened the secret door from the bedroom, but I have to check my notes.

    @Martin. My book doesn’t contain the erratum so ít would be very nice if you publish it. I hope when I use it, it wil sove the problem and at last there will be an English version available. (It took me 3 nights typing. It would be nice if I didnt do it in vain 🙂 )

    Tonight I’ll update my map and the list of objects. Should be nice if we can finally solve this game.

    Kind regards,

  16. Post
  17. Thanks, Martin for the scan, but unfortunately the game still gives an error. There is something wrong with displaying the names of the locations. To prevent the error I changed the code in skipping the display of the location names. The rest of the program seems to work fine but it’s not really playable like this unless you know the locations by heart. I”ll try to fix the error but it seems a bit diificult.

    I’ll send you a list of all the verbs and nouns (German, Dutch and English)recognised by the game together with a list of all 50 objects and their location at the start of the game. The roomnumbers are the actual numbers the game uses. They are on the map I am revising at the moment and which I’ll will send as soon as I’ve completed it.

    Kind regards,

  18. I opened the secret door from the enchanted room and came out in the bedroom too! I also opened the secret door from the bedroom. Apparently the inscription in the SE tower is for a room in the SW tower :). I’ll still try to find out if the magic-potion works to escape from the enchanted room to the corridor next to the gambling-hall…

    Thank you, Martin and Alex, for the tips! I’m free tomorrow and will play from dusk to dawn!


  19. Yeah! I finished the game with all the spells and the magische eenheid without using any of them. HOWEVER, having visited all the rooms, bribed all the gatekeeper, pleased the priest and the girl by giving them gifts, the maximum score I got -as calculated before- is 230…

    @ Martin: do you know if 240 is really possible? And if so: any ideas on how to generate the last ten points? Or have I now finished the game as it should be played… (where are the fireworks, the rockets, the cheers to greet the great journalist ??)


  20. Hi Martin,

    I can’t remember if I have pointed this out before, but in the Dutch version of the Arendarvon site it says that stop means to stop (ophouden), but it is incorrect. In the game the Dutch word stop is to mean to put something in something (iets stoppen in iets).


  21. Some more tips: you can take the keys from the guardian and the ‘magische eenheid’ from the wizard, but these are very rare events and you might need to reload a saved game many times before you get lucky.

    The encyclopedia is in the bookcase, but not visible if you examine it.

  22. Hi. Arend Rensink, the author of The Secret Of Arendarvon Castle (the game and the book) has uploaded scans of the English version of the book for the BBC Micro computer here:

    Unfortunately, the scan-resolution wasn’t high enough for me to type in the listings accurately, so I contacted Arend and he kindly provided higher-fidelity scans and OCRs, which helped a lot. I have now managed to get game running, under emulation.

    A disc-image of the English version of the game for BBC Micro is available here:

    It can be played in the BeebEm emulator, which is here:

  23. Hello,
    Does anyone know where the copyright to the game and story lie now? Is it still with Addison-Wesley publishers? Or does Arend Rensink has it? Is he Dutch? The Dutch translation was done by Herman Rensink? Maybe family?
    The Dutch version was done by Omikron publishers. Do do not seem to exist anymore.
    Greeting Mark

  24. Does anyone still have the scans? I remember this game from when I was young and I never managed to solve it. I would like to try again, but I am sure that the book is very helpful/needed to solve it. As google+ is now gone, that link is dead…

      1. Thanks, I only just saw your answer. I got it now. Now let’s see if I can solve it… When I was a young boy I wasn’t able to.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.